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New Features and Enhancements 2021.2 
 

Release Highlights 
 
Inspire Python API 

Inspire now includes an easy-to-use Python API layer with classes to create user interface components like widgets, dialogs, and 
menus, as well as classes to exercise Inspire core functionalities including objects, boundary conditions, geometry, and graphics.  

 

View Cube 

A new navigation cube has been added to the view controls in the lower left corner of the modeling window, replacing the old View 
Rotator.  

 

Extrude, Pattern, and Offset Geometry Tools 

Three new geometry tools have been added that enable you to: 

• Extrude sketch profiles in one or two directions. Create a new part or combine, subtract, or intersect the extruded shape with 
existing parts. 

• Create a linear or circular pattern of parts or faces. 

• Offset parts or surfaces. You can also thicken parts. 

 

Spot Welds for SimSolid Analysis 

Spot welds can now be applied to solid parts. Use the SimSolid solver when analyzing spot welds for solids and the OptiStruct solver 
when analyzing spot welds for surfaces. The solver can be set in the Preferences under Inspire > Run Options > Analysis solver. 

 

Radial Constraints and Obstacles 

Radial constraints have been added to the Shape Control tools, and you can now designate parts as obstacles when defining single 
draw, split draw, and radial draw shape controls. 

 

Flexible Bodies and Eigen Analysis for Motion 

The new FlexBody tool can be used to convert rigid bodies to flexible bodies and to review flexible body modes before running motion 
analysis. Eigen analysis has also been added as an option in the Motion Run Settings to predict stability and natural frequencies of 
vibration modes, and the motion patterns of vibrating systems. 

 

Optimize Orientation Tool for Print3D 

Use the new Optimize Orientation tool to minimize print time, supports, and/or deformation for additive manufacturing. 
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Inspire Python API 
Inspire now includes an easy-to-use Python API layer with classes to create user interface components like widgets, dialogs, and 
menus, as well as classes to exercise Inspire core functionalities including objects, boundary conditions, geometry, and graphics.   

Take advantage of the API to execute Python scripts in pure batch mode without UI or graphics, to run macros from the Python 
command window, or to kick off a Python script on startup. Use the API to create an entirely new major functionality ribbon, or use it to 
add new icons to an existing ribbon, whether to add on to Inspire functionality or to launch another product.  

Find everything you need for extension development packaged with the installation:  

• The most commonly used Python modules are contained in the distribution.  

• An IPython command window is integrated with Inspire, allowing execution of commands interactively. 

• A batch mode option allows silent execution of the script. 

 
Get Started 
The basics of how to use the Inspire Python API are covered in the Inspire API online help, which includes packaged references. 
 
Explore Examples  

Inspire provides demos of available components with the source code to implement them, allowing you to modify the code and run it to 
see the results in real time.  

Learn about the interactive dialog where you can tour the components in our Quickstart Demos. To access the demos, click File > Help 
> Python API Demos 
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Manage Extensions  
An extension provides the means to extend the application through shared libraries or scripts. Use extensions to create new profiles, 
contexts, model views, and more. 

Sample extensions that illustrate the various use cases are included in the Extension Manager. Click File > Extension Manager to 
view information on creating extensions and managing them. 

 

 

View Controls 
 
View Cube 

A new navigation cube has been added to the view controls in the lower left corner of the modeling window, replacing the old View 
Rotator. 

 

• Clicking the arrows incrementally rotates the view. Left- and right-clicking increments by + and - 15 degrees while middle-

clicking increments by 90 degrees. 

• The display and behavior of the View Cube can be adjusted in the Preferences under 

File→Preferences→Inspire→Visualization. 
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Geometry & PolyNURBS 
Extrude Tool 

Use the Extrude tool to extrude sketch profiles in one or two directions. Create a new part or combine, subtract, or intersect the 
extruded shape with existing parts. 

 

 

 

Pattern Tool 

Use the Pattern tools to create a linear or circular pattern of parts or faces. 
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Offset Tool 

Use the Offset tool on the Geometry ribbon to offset parts or surfaces.  

 

 

 

 

PolyNURBS Editing Filters 

Filters are now available when editing PolyNURBS that allow you to restrict selection to vertices, edges, or faces. There is also an 
option to filter based on selection. For example, if you select an edge, then it will filter on edges. Click on empty space to reset the filter 

 

 

Additional Changes and Enhancements for Geometry 
 

• The sketch Intersect tool can now be applied to parts or surfaces. 

• Inspire now reads surface color meta data from Catia files. 
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Structures 
 
Spot Welds for SimSolid Analysis 

Spot welds can now be applied to solid parts. Use the SimSolid solver when analyzing spot welds for solids and the OptiStruct solver 
when analyzing spot welds for surfaces. The solver can be set in the Preferences under Inspire > Run Options > Analysis solver. 

 
 
Radial Constraints 

A radial draw direction is a type of manufacturing constraint. It is used when a machining tool needs to enter in a radial direction toward 
the center of the plane  

 

    

 

Obstacles 

To designate parts as obstacles, use the  icon on the microdialog when applying a single, split, or radial draw direction. Enabling this 
option will ensure that during optimization, material is built in the draw direction all the way to the obstacle parts. 
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Additional Changes and Enhancements for Structures 
 

• Enhanced tooltips have been added for all microdialogs and guide bars on the Structures ribbon tools. 

 

Motion 
 
Flexible Bodies 

The Motion module for Inspire supports two kinds of bodies: rigid and linear flexible. The rigid body operates in 3D space where it can 
undergo large overall motion, be attached to other bodies via joints, and/or get into contact with other bodies, but it cannot experience 
any deformation. The linear flexible body can do the same, but in addition can undergo small deformations. A linear flexible body is 
useful in situations where deformations of the body due to large forces have a meaningful impact to the overall behavior of the system 
and the forces at the pivot points.  

There are two ways to create flexible bodies. The simplest is to right-click on a part, select Flexible for Motion from the context menu, 
and then run a motion analysis. Alternatively, you can use the FlexBody tool on the Motion ribbon to create flexible bodies, specify the 
number of flex body modes and whether to include stress and strain in the analysis, and to review flexible body modes. 

 

 

 

Eigen Analysis 
General multibody systems are almost always nonlinear, but nonlinear systems are difficult to analyze in regard to stability and 
vibration.  

Inspire Motion now allows you to linearize your model by running an Eigen analysis to calculate the eigenvalues and normal modes. 
Eigenvalues predict stability and natural frequencies of vibration modes, while normal modes help you understand the motion patterns 
of vibrating systems. 

Use the Run Motion Settings window to perform an Eigen analysis.  
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When reviewing motion results, click the  icon on the Animation Toolbar to open the Eigen Modes table: 

 

 

 

Additional Changes and Enhancements for Motion 
 

• Enhanced tooltips have been added for all microdialogs and guide bars on the Motion ribbon tools. 
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Print3D 
 
Optimize Orientation 
The new Optimize Orientation tool allows you to find the best orientation for the print part based on three different criteria - print time, 
supports, and/or deformation. 

 

• Printing Time 

• Supports  

• Deformation  

You can define a weight for each of these criteria to define the best balance for your print requirements and use the Average color map 
to select the optimal orientation. 
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Multiple Parts in Print Bed 
You can now select and lay out multiple parts in the print bed, then define the orientation and apply supports for each print part 
individually. When you run the simulation, the analysis will  consider all the parts jointly in its calculations. 

 

 

Additional Changes and Enhancements for Print3D 
 

• Enhanced tooltips have been added for all microdialogs and guide bars on the Print3D ribbon tools. 

 

Resolved Issues 
• Fixed an issue where Inspire could not be docked to the task bar in Windows 10. [IN-19158] 

• Fixed an issue with a mesh failure due to a large difference in element size. [IN-22845] 

• Fixed an issue where normal modes would not run with multiple supports. [IN-20940] 

• Fixed a crash on File > New after reorganizing parts in the Model Browser. [IN-26127] 

• Fixed an issue where surfaces would merge resulting in bad elements. [IN-25901] 

• Fixed an issue where Inspire failed to properly cut a complex part. [IN-25420] 

• Fixed an error in SolidWorks import where parts were imported out of position. [IN-24943] 

• Fixed an issue where analysis could not be run using the More Accurate setting. [IN-22871] 

• Fixed a failure to mesh a surface part. [IN-20405] 
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Known Issues  
• If the Auto Find preference is turned off for contacts, an extra contact is found at run time. [IN-25015]. 

• Incorrect radial bead pattern causes solver error. [IN-16311] 

• Cannot load lattice structures from Siemens NX files. [IN-25142] 

• Callouts not supported for flexible bodies in the in the Analysis Explorer. [IM-3943] 

• Joint connections for flexible bodies are set to Flexible by default. [IM-3661] 

• Pressures are not supported for flexible bodies. [IM-3705] 

• instances of rigid bodies are not supported for flexible bodies. [IM-3489] 

• User interface localization incomplete for some new features, including workflow help for the Extrude, Pattern, and Offset 

tools. [STDOC-2004] 
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New Features and Enhancements 2021.2.1 
 

Altair Inspire 2021.2.1 includes the following new features, enhancements, or resolved issues. 

 

Resolved Issues 
• Fixed an issue where results couldn’t be viewed if an analysis was run on a surface model on Linux. [IN-26300] 

• Fixed a crash found when loading a model containing a connector. [IN-26319, IN-26337, IN-26338, IM-4081] 

• Fixed a crash when editing connectors that were created in Inspire 2021.2. [IN-26359] 

• Fixed a crash when editing polygons in sketch. [IN-26298] 

• Fixed a regression in a connector’s auto center and position where their values failed to update in the preferences. [IN-26357] 

• Fixed a Python API call that was causing a crash on viewing the results. [IN-26274] 

• Fixed an issue where no results were displayed after selecting Review Flex Body Results; if a model was solved with any part 

made flexible, and there were parts configured off, no Flex Body Results were available. [IM-4074] 

• Fixed an issue where load stress results couldn’t be loaded for Flex Body; if a model was solved with any part made flexible, 

and there were structural masses defined in the model, no Flex Body Results were available. [IM-4085]. 

• Fixed an issue where a single left-click was not removing the Quick Plot. [IM-4080] 

 

Known Issues  
• Binder Sinter will not work when the license is set from the Inspire License dialog. It works when the license is set by the 

environment variable. (Binder Sinter is only available when you turn on the Upcoming Features.) 

• The number of units required to run Binder Sinter is 45. (Binder Sinter is only available when you turn on the Upcoming 

Features.) 
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Learn More About Inspire 
 

You can learn more about new and existing features in Inspire using the following resources: 

In-Application User Assistance 
Inspire provides two types of user assistance. Enhanced tooltips appear when you hover over icons and other features. They describe 
what the tool does.  

 

 
Workflow help appears when you select a tool that opens a guide bar or microdialog. The text prompts you what to do next.  

 

 

Click  to view additional tips and shortcuts. Some tools also include a video . 

 

 

Online and Offline Help 
Press F1 or select File > Help > Help to view the online help.  
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