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New Features and Enhancements 2021 
Altair Inspire 2021 includes the following new features and enhancements. View resolved issues for the 2021.0.1 hotfix here and 
2021.0.2 hotfix here. 

 

Structures 
 
Refine Results Option for SimSolid Analysis 

In cases where SimSolid results are poorly tessellated, you can now right-click on the part and select Refine Results to refine the 
tessellation.  

    

 

Export .ssp Files for SimSolid 

You can now export .ssp models for SimSolid runs by clicking the Export button in the Run SimSolid Analysis dialog.  
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Reaction Forces for Fasteners 

Use the new Fasteners Table icon on the Animation toolbar to extract reaction forces at fasteners. 

 

 

 
 
Convert Part to Mass Option 

You can now convert a part or parts to a point mass to simplify the simulation and make it run faster. Right-click on the parts and select 
Convert to Mass in the context menu. The mass will still need to be attached to the rest of the structure.  
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Additional Changes and Enhancements for Structures 
The following changes and enhancements have also been added for version 2021: 

 

Thermal Properties for Materials 
Thermal properties have been added to materials. 

 

 

Enhancements to Connectors 

An option to automatically calculate the center of the surface has been added to the Property Editor for connectors. In addition, 
connectors are now visualized without the “spider” lines, unless explicitly added using the Connectors tool. 

 

 

Contact Force Results 

Inspire now extracts contact force results for normal, tangential, and traction forces when running OptiStruct analysis. 
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Fading Mesh Lines 

Mesh lines now fade when you zoom out in the modeling window. This creates a cleaner appearance for large models. 

 

 

 

Maximum Bead Fraction 

For topography optimization, there is now an option to Use Bead Fraction and to define a Bead Fraction Upper Bound in the Property 
Editor. 
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Below you can see the difference when the bead fraction upper bound is set to 0.25 vs 0.75: 

    

 

Refresh Query Results for PDM 
When opening files from a Product Data Management (PDM) system, you can now select Check for updated parts on the Open from 
PDM System window to automatically refresh the query results. Out-of-date parts are shown in red in the list of files. 
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This option can also be set in the Preferences, under Inspire > Geometry > PDM. Use the Timer setting to determine how often to 
automatically refresh the query results. 

 

 

Surface to Surface Contacts for OptiStruct Analysis 

OptiStruct analysis now supports surface-to-surface and node-to-surface type contacts. 
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Motion 
 
Cylinder and Hole Feature Pair Detection 

The At Cylinders and Holes option on the motion contacts guide bar will now automatically detect Cylinder and Hole candidate pairs. 
During creation, the guide bar arrows let you navigate through the detected pairs so you can 1) accept the selections in the contact 
sets, 2) Ctrl + left click on features to add/remove them from the contacts sets, or 3) navigate through individual features for the 
currently active contact set by holding down Ctrl while clicking the guide bar arrows.  

   

Additionally, a checkbox for filtering out skewed holes has been added to the Find Options menu and we have improved the positioning 
of glyph icons to be located nearer to the contacting features. 

 
Virtual Option for Joints 

A new Virtual option has been added to motion joints, which is useful for overcoming redundancies in rigid joints for motion analysis. 
This alternative to idealized joints allows for some compliance and can be used in applications like couplers and joints with friction 
enabled, where previously you were required to make the joint rigid.  Now you can specify the Virtual option on an individual joint basis 
using the Property Editor, or on a global basis from the Motion Run Settings window. 
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Time History Plots for Structures Callouts 

The Analysis Explorer now has a Plot button that can be used to display time history plots for callouts defined for structural analysis. 
Changes made to the Result Types option are synchronized with the setting on the Analysis Explorer. Using the Callout option allows 
you to put multiple plots of mixed types on a single page. 

 

 
Range for Motion Animation Playback 

A new Range option is available in the Animation Settings dialog to specify the Start and End times (or frames) for motion animation. 
This allows you to limit the playback range to just a portion of the animation, making it easier to study behaviors in more detail. You can 
use the Ctrl key while clicking on the Start or End icons to jump to Range Start and Range End, respectively. You can fit plots for the 
selected range by using the Ctrl key while double-clicking. Also, the paths of tracers will be trimmed to honor the specified range. 
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Additional Changes and Enhancements for Motion 
The following changes and enhancements have also been added to Inspire Motion for version 2021: 

 

Change to Quick Run Behavior 

Instead of launching a new run, the Motion Quick Run button will now begin playing back motion animation results when available, 
provided that the End Time has not been changed and nothing in the model has been changed. The animation playback can be 
stopped by pressing the Pause button on the Animation toolbar or by pressing the Esc key to exit the tool. Note that if you prefer to 
execute a new motion analysis, hold down the Ctrl key as you click the Motion Quick Run icon. 

 

 
Reset Options on Motion Contacts Microdialog 

The Motion Contacts microdialog now has a Reset option for restoring the default values of parameters. You can either restore all 
defaults or just those that are currently visible in the microdialog. 

 

 

Improved Guide Bar Design 

The guide bars for Rigid Groups and Motion Contacts now display a checkbox with text to clarify what the secondary action for the Play 
button is, such as Ungroup or Individualize. 
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Filter Buttons for Structures Entities on Force Explorer 

The Force Explorer now has dedicated filter buttons for supports, forces, and torques. 

 

 
Plotting Context Menu Improvement 

The right-click context menu for motion plots now shows the option currently being plotted as greyed out. 

 

 
10% Extension for Calculate End Time Button 

Holding down the Ctrl key when clicking the Calculate End Time button now adds 10% more time. This is handy for seeing model 
behavior after the profile has ended. 
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Scrollable Legend for Motion Plots 

A vertical scrollbar now appears in the legend area when the number of rows in the legend is greater than three. This is useful when a 
lot of curves are being plotted simultaneously or when the legend label text is lengthy. 

 

 

Start Time Column Added to Actuator and Motor Tables 

The motion profile Start Time parameter is now accessible from the Motor and Actuator tables. 
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Print3D 
 
Improved Support Types and Parameters 

The Print3D Supports tool has been improved, and now allows you to generate multiple support shapes in addition to optimizing time 
and materials. Available support types include block, rod, H-cell, tree, and feature a variety of options to control the support pattern, tip, 
and other parameters. 

    

Tree Supports      H-cell Supports 

 

    

Rod (Pin) Supports      Block Supports 
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Manual Supports 

You can now generate manual supports in any region of the part based on your specific requirements. 
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General 
 

Demo Browser 

A demo browser has been added to allow quick access to tutorial model files. The Demo Browser can be opened using the View menu 
or by pressing F7. Double-click a model from the list to open it, or drag-and-drop it into the modeling window. 

 

Watermark Image 

You can now add a .png or .jpeg image as a watermark in the graphics window. Simply rename the image “watermark” and add it to the 
Documents/Altair/2021/Inspire folder on your computer. 
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Resolved and Known Issues 
Resolved and known issues are listed in the online help. To view the latest information, go to File > Help > What’s New. 

 

New Features and Enhancements 2021.0.1 
Altair Inspire 2021.0.1 includes the following new features, enhancements, or resolved issues. 

Resolved Issues 
• Fixed an issue where STL instances did not work correctly after using the Section Cut tool. [IN-23534] 

• Fixed an issue with incorrect thickness when running a reanalysis after gauge optimization. [IN-23592] 

• Fixed an error that mistakenly caused the Intersecting Parts Found in Model warning to appear and to subsequently prevent 
Analyze Part workflows from proceeding forward. [IN-23666] 

• Fixed an issue where the Convert to Mass feature was not giving the correct answer because the mass moment of inertia 
value was not being converted with the mass. [IN-23718] 

• Fixed an issue where models created in Inspire 2021 that had parts or assemblies deleted or imported in between runs could 
not be reopened. [IN-23961] 

• Fixed a traceback error seen in motion contact models when specifying HM as the SkinMesherMV setting via the 
devPreference.xml file. [IM-3592] 

• Updated the plot range fitting behavior so that it will exclude curves whose appearance has been hidden by using the clickable 
legend. [IM-3654]. 

• Fixed the browser in the Plot Manager so that it once again displays information in parentheses for joints, actuators, and 
motors, which had been missing from the 2021 release. [IM-3665] 

• Updated motion animation file handling to allow generation of the .h3d file even in the case of analysis failure or when 
manually stopping the motion analysis before it has reached the specified end time. [IM-3666] 

• Re-established the default value for penetration depth in motion contacts to be 0.1 mm, bringing it back to the value used 
previously in 2019.1 and earlier releases. [IM-3668] 

• Updated the behavior of Reset -> Visible Defaults on the motion contacts microdialog so that it does not alter values that are 
not currently being shown on the screen. [IM-3672] 

• Fixed traceback error seen when entering the Joints tool for reported use case. [IM-3679] 

• Fixed the Export Image feature in the Profile Editor so that it works as intended again. [IM-3714] 

• Corrected entries in the Plot Manager browser to better handle the case when objects share the exact same name (are not 
unique). [IM-3724] 

• Updated the Motion Contacts guide bar touring behavior for the Next and Previous location buttons. [IM-3736] 
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New Features and Enhancements 2021.0.2 
Altair Inspire 2021.0.2 includes the following enhancements and resolved issues. 

Enhancements 
• Inspire 2021.0.2 has upgraded its support for the following geometry file formats: 

o JT through version 10.5 

o Pro/Engineer through Creo 7 

o NX (Unigraphics) through CR 1953 

Resolved Issues 
• Fixed an issue where axial and sheer force results were reversed for fasteners. 

• Fixed an issue where some parts in a JT assembly did not import in the correct position.   
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Learn More About Inspire 
You can learn more about new and existing features in Inspire using the following resources: 

In-Application User Assistance 
Inspire provides two types of user assistance. Enhanced tooltips appear when you hover over icons and other features. They describe 
what the tool does.  

 

 
Workflow help appears when you select a tool that opens a guide bar or microdialog. The text prompts you what to do next.  

 

 

Click  to view additional tips and shortcuts. Some tools also include a video . 

 

. 
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Online and Offline Help 
Press F1 or select File > Help > Help to view the online help.  

 

 

You can download an offline version by selecting File > Help > Download Offline Help. An internet connection is required to 
download. 
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