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New Features and Enhancements 2025 

Geometry 
 

Rib Tool 

The Rib tool now includes an Advanced Options section so you can choose presets for materials or manufacturing types or enter 

custom settings. 

 

For more information, see Rib. 

 

Slice Tool 

When working with the Slice tool, you can now select a plane or surface in the Model Browser to quickly define the cut path. 

For more information, see Slice. 

 

Trim/Split Tool 

When working with the Trim/Split tool, you can now select sketches or sheet parts in the Model Browser to quickly define the tools. 

For more information, see Trim/Split. 

 

Geometry File Formats 

Updated file format to include PTC Creo (.asm, .prt) 13 through Creo 11, UG NX (Unigraphics) (.prt) 11.1 through CR 2406, and 

SolidWorks (.sldasm, .sldprt) 99 through 2024. 

For more information, see Geometry File Formats for Import. 

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/geometry/rib_t.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/geometry/cut_parts_st_t.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/geometry/project_split_t.htm
https://help-staging.altair.mediag.com/2025/inspire/en_us/topics/shared/unity_basics/file_formats_st_r.htm?hl=geometry%2Cimport#reference_mfd_4k2_jr__section_fhm_3hh_vz
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Sketching 
 

Image Plane 

The Sketch ribbon now includes an Image Plane tool. Use it to add a background reference image, so you can trace lines and curves to 

start your design. 

 

For more information, see Image Plane. 

 

Sketch Axes 

You can now select the red and green axes in the sketch grid to quickly create dimensions and constraints. 

 

For more information, see Sketch Constraints, Dimension, Mirror, and Linear Pattern. 

 

Break External Sketch References 

Right-click a sketch in the modeling window or the Model Browser and choose Break External References from the context menu. 

Any dimensions, constraints, or relationships that have references to other features are removed. Any independent sketch dimensions, 

constraints, or relationships are retained. If the sketch contains any projected or intersected entities, they are converted to regular 

sketch entities, and the references are removed. 

For more information, see Break External Sketch References. 

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/sketching/sketch_image_plane_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/sketching/sketch_constraints_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/sketching/dimension_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/sketching/offset_mirror_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/sketching/pattern_sketch_c.htm#task_w3l_rtd_25b
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/sketching/break_sketch_refs_t.htm
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Sketching Enhancements 

Changed how vertices are merged in sketch entities to improve parametric referencing such as projections and intersection curves and 

chain selection of edges for sketch offsets. 

When a sketch is defined on a face, projection curves are now extracted instead of intersection curves. 

For more information, see Sketch Context Menu Options, Sketch Plane, and Intersect. 

 

PolyNURBS 
 

PolyNURBS Visualization 

Updated PolyNURBS cage faces and edges. 

 

For more information, see Editing PolyNURBS. 

 

PolyNURBS Primitives 

You can now draw a surface or box to create a PolyNURBS surface or solid. 

 

For more information, see Create a PolyNURBS Surface or Create a PolyNURBS Solid.  

 

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/sketching/sketch_context_menu.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/sketching/sketch_plane_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/sketching/sketch_context_menu.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/geometry/polynurb_edit_st_t.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/geometry/polynurbs_create_c.htm#task_m2k_kedim
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/geometry/polynurbs_create_c.htm#task_m2k_kgd_wv
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Implicit Modeling  
 

Custom Planar Lattices 

In the Planar Lattice tool, choose Cell Type > Create Unit Cell to edit or create new unit cells. Unit cells can be exported and imported 

into another design. 

 

For more information, see Create an Implicit Planar Lattice. 

 

Convert Surfaces and Curves to Implicit 

The Implicit Convert context has been improved to allow you to convert parts, surfaces, or curves to implicit equivalents that you can 

use in downstream tools such as Offset or Field. 

 

For more information, see Convert to Implicit Geometry. 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/implicit/planar_t.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/implicit/convert_t.htm
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Surface Perforations 

When generating a point-edge set from a converted part or surface, you can now create uniformly spaced points on the surface based 

on the UV parametrization of those objects. You can also generate struts that project outward/inward from the surface normal to 

produce struts that can be used as pins or to perforate the target body. 

 

For more information, see Create Implicit Surface Perforations. 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/implicit/surface_perforations_t.htm
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Conformal Improvements 

UVW grid lines are now drawn for the parametrized curve, surface, or volume being generated for a better preview of the definition of 

the conformal mapping. A new conformal mapping has been added to allow a conformal space to be generated between two surfaces. 

This ensures that the unit cells terminate cleanly on both surfaces. 

 

For more information, see Conformal Coordinate Spaces. 

 

Point-Edge Set Improvements 

New point and edge generation methods have been added to the Point-Edge Set context to extract struts from mesh data connected to 

the target object. 

 

A new trimming filter allows you to slice struts with respect to a target body’s volume. 

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/implicit/conformal_spaces_c.htm
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A new snapping filter allows you to snap points that are within a chosen distance to the surface of the target body. 

For more information, see Create an Implicit Strut Lattice. 

 

Implicit Fields from Simulation Data 

 

The workflow for generating an implicit field from simulation data has been greatly improved. For compatible solver types (OptiStruct 

and Inspire Fluids results), a new Create Field button allows direct creation of an implicit field. Topology optimization alternative shapes 

can be selected within the Field guide panel to extract the density results directly into an implicit field. 

 

For more information, see Create Implicit Fields from Analysis Results. 

 

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/implicit/strut_t.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/implicit/implicit_fields_from_analysis_t.htm
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Rendering 
 

Depth of Field (Performance Mode) 

Depth of Field is now available as an approximation in Performance Mode. 

 

For more information, see Define the Camera's Rendering Quality. 

 
 
Alpha Channel Support 

Final rendering can be saved as either a .tiff (with alpha) or .png (with alpha). 

 

Without alpha channel 

 

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/studio/unity_basics/camera_c.htm#task_cd1_3sn_3fb
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With alpha channel 

 

For more information, see Create and Save a Rendering. 

 

 
Physical Lights 

Point lights can be added to a scene for additional illumination control. 

 
 

For more information, see Add Physical Lights. 

 
 
Camera Edit Panel Updates 

Reorganized options in the camera editor panel to simplify the workflow. 

For more information, see Define the Camera's Rendering Quality. 

 

 

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/studio/rendering/final_rendering_c.htm#task_s3b_cwj_cfb
https://2025.help.altair.com/2025/inspire/en_us/topics/studio/rendering/lights_add_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/studio/unity_basics/camera_c.htm#task_cd1_3sn_3fb
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Structure 
 

Spot Welds 

Improved workflow and guide panel for creating spot welds. 

 

For more information, see Spot Welds. 

 

Structure Variables 

Variables can be assigned to forces, pressures, torques, enforced displacements, and angular velocity/acceleration. 

 

 

For more information, see Forces, Pressures, Torques, Enforced Displacements, Angular Velocity/Acceleration, Variables, and Manage 

Design Variables. 

 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/structure/spotwelds_inspire_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/structure/force_inspire_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/structure/pressure_inspire_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/structure/torque_inspire_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/structure/disps_enforced_inspire_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/structure/accels_angular_inspire_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/variables/variables_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/design_explorer/input_variable_st_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/design_explorer/input_variable_st_c.htm
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Material Variables 

Variables can be assigned to materials and are available in the Variable Manager and Design Explorer. Material variables allow you to 

easily evaluate your design with multiple materials. 

 

 

 

For more information, see Assigning Materials, Variables, and Manage Design Variables. 

 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/materials/materials_assign_inspire_t-1.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/variables/variables_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/design_explorer/input_variable_st_c.htm
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Named Object Variables for Python Properties 

In the Variable Manager, you can create variables for an object’s Python properties.  

As you type the object name and the Python expression you want to use, the dropdown displays the available Python metadata. 

Creating variables for Python properties provides access to extensive metadata and makes it easy to use metadata in reports. 

 

For more information, see Create Variables from Python Properties and Inspire Python API. 

 

SimSolid Solution Settings 

Solution Adaption controls in Run SimSolid Analysis have been updated with Solution Settings that allow you to adjust settings globally 

(for the assembly) or locally (for groups of parts). 

 

For more information, see Run Options: SimSolid vs OptiStruct. 

 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/parametric/variables/create_variables_python_t.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/reference/python_api_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/structure/analysis_inspire_c.htm#reference_ugb_gjl_b2b
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Report Settings 

The Report Settings dialog now allows you to include an animation of all selected items on the Results tab. Animation is available only 

when saving the report to .ppt format. 

 

For more information, see Customize the Report Settings and Create a Report. 

 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/structure/report_t-1.htm
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Quick Switch to Rainbow Color Legend 

The Legend Options menu in the Analysis Explorer now includes a Rainbow Legend Colors option to change the legend color 

quickly. 

 

For more information, see Analysis Explorer Options. 

 

Show Section Cuts in Part Color 

The Section Planes tool now includes a Show Section Cuts in Part Color option. 

 

For more information, see Create a Section Cut. 

 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/structure/analysis_explorer_options_r.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/unity_basics/view_section_cuts_st_t.htm
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Motion 
 

Flex Bodies of Rigid Groups 

You can now make a single flex body out of a rigid group. Individual parts are bonded at their contacting interfaces and can take into 

consideration separate material properties. 

 

For more information, see Create a Flexible Body. 

 

Joint Limits 

You can now limit the distance or angle that a joint can travel or rotate through. This means that you can add virtual stops to your joint 

in the absence of, or in place of, the geometry needed for motion contacts. There are options to enter limit values either by using a 

graphical manipulator or a microdialog. Limits apply to all joint types except Ball and Socket and Contact joints. 

 

For more information, see Joints. 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/motion/create_flexible_body_t.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/motion/joints_c-2.htm
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Display Joints as Detected Features 

A new option in the Joint microdialog allows you to toggle the joint graphic representation between the original (detected) features or 

the corresponding kinematic joint type. 

 

For more information, see Add/Edit Joints. 

 

New Design Variables for Motion Design Exploration 

Static and dynamic contact friction coefficents and static and dynamic joint friction coefficients are now supported as variables, which 

allows them to be used in a Design Exploration study. 

 

For more information, see Variables in Inspire Motion. 

 

FMU Export 

You can can now assign input and output signals for exporting a MotionSolve FMU block. Use the Input/Output Signals dialog to define 

signals quickly and easily by selecting from specific model inputs and outputs. 

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/motion/add_edit_joints_c.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/motion/variables_motion_c.htm
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For more information, see Export Motion Results. 

 

Multiselect When Creating Motion Contacts Using “At Free Joints” 

You can now rapidly add multiple contact definitions based on Free joint types.

 

 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/motion/export_motion_results_c.htm
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Fluids 
 

Simulation of Implicit Parts 

Implicit parts can be included as embedded solids in Fluids simulations. This enhancement provides a seamless integration of implicit 

and non-implicit solids for conjugate heat transfer simulations without needing to convert the implicit parts into a different format such as 

STL. In this release, multi-fluid lattice heat exchangers, natural convection, porous media, and rotating components are not supported 

when implicit parts are present in the simulation. 

 

 

  

http://altair.com/
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Natural Convection  

Fluids simulations can now model the effect of thermal gradients on velocity fields, driven by buoyancy effects. Enable the Variable 

Density option and choose the Boussinesq or Ideal Gas model to simulate natural convection dominated applications. In this release, 

natural convection is not supported when implicit parts are present. 

 

 

For more information, see Fluid Domain. 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/cfd/liquid_domain_t.htm
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Porous Media 

The new Porous Media tool models the effect of screens, filters, and other porous solids in the fluid flow. You can estimate the pressure 

loss incurred due to porous parts and evaluate the overall system performance in applications with porous components. In this release, 

porous material with isotropic or uni-directional porosity are not supported, and porous media is not supported when implicit parts are 

present. 

 

 

For more information, see Porous Media. 

 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/cfd/porous_media_t.htm
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Rotating Components Update 

It is now possible to set the axis of a rotating component to an axis other than one of the cardinal global axes. This is useful when the 

rotating component is not aligned along the global x/y/z axes. Select the “Custom” option under Rotation Axis and pick any face on the 

rotating component to automatically generate a virtual rotating volume whose axis is aligned with the component’s rotation axis. In this 

release, rotating components are not supported when implicit parts are present. 

 

For more information, see Rotating Components. 

 

Mass Flow Rate Inlet Boundary Condition 

There is a new option, Mass Flow Rate, in the Inlet microdialog. You can specify a known mass flow rate entering the domain at an 

inlet face. 

 

For more information, see Inlets. 

 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/cfd/rotating_component_t.htm
https://2025.help.altair.com/2025/inspire/en_us/topics/cfd/inlet_t.htm
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Volumetric Rendering Controls  

In the Analysis Explorer, you can now control the transparency based on minimum or maximum values of the currently displayed result. 

Using this additional control, better insights into the 3D flow and thermal fields can be gained by selectively showing or hiding the critical 

flow regions. 

 

 

For more information, see Style Options. 

 

Face and Part Callouts 

Callouts are now available for part faces and parts, in addition to the existing point callouts. You can also view all callout values in the 

callouts table. 

 

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/cfd/show_cfd_analysis_results_t.htm#reference_zzr_bqg_hsb
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For more information, see Callout Options. 

 

Refinement Zones Updates 

You can now translate and rotate refinement zones when you create them. This feature can be used to better align the refinement 

zones with non-axis-aligned regions of interest. 

 

For more information, see Custom Fluids Run. 

 

 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/cfd/show_cfd_analysis_results_t.htm#callout_options_fluids_r
https://2025.help.altair.com/2025/inspire/en_us/topics/cfd/run_cfd_analysis_t.htm#cfd_run_settings_r
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Streamline Length  

You can now increase the maximum streamline length in the Analysis Explorer. This is helpful when modeling complex topologies and 

the default streamline length is too short. 

 

 

For more information, see Style Options. 

 

Export Results in H3D Format 

Pressure, velocity, and temperature results from simulations can be exported in H3D format for both Fluid and Solid components. You 

can enable H3D export from the Fluids Preferences window by selecting the “Write .h3d for PhysicsAI” option. The resulting H3D files 

for all parts are exported to a folder named “asciiandfem_results” under the simulation’s run folder. 

 

For more information, see Customize the Report Settings and Create a Report. 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/cfd/show_cfd_analysis_results_t.htm#reference_zzr_bqg_hsb
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/structure/report_t-3.htm
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Print3D 
 

Prepare Window Updates Including Base Plate Controls 

You can now use the SLM ribbon’s Printer window customize printer information, including laser speed, laser diameter, and recoating 

time. This information lets Inspire calculate printing time more accurately.  

 

There is also a new tab that includes controls to customize the printer’s base plate. 

 

For more information, see Printer. 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/inspire/3Dprint/printer_print3d_t.htm
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General 
 

Physics AI Extension 

 

Physics AI is now available as an extension from the Extensions Manager, which can be found under File > Extensions. 

 

 

  

http://altair.com/
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Altair Copilot Beta 

 

Altair Copilot is an AI-powered support assistant that understands natural language and can answer questions based exclusively on 

Altair's online help material and other Altair knowledge sources. 

 

For more information, see Altair Copilot (Beta). 

  

http://altair.com/
https://2025.help.altair.com/2025/inspire/en_us/topics/shared/unity_basics/altair_copilot_r.htm
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Python API 
 

Geometry 

 

• Enhanced rib API with advanced options.  

• Enhanced chamfer API with tangent propagation and swap chamfer sides. 

• Added a property on Part to get its instances.  

 

Implicit Modeling 

 

• Added API support to convert surfaces and curves to implicit. 

• Added API support to create fields from simulation data. 

• Added API support to surface perforations. 

• Added API support to custom planar lattices. 

• Added API support to trimming filter. 

• Enhanced the createField API with unsigned argument to allow positive field values from the driving object. 

• Enhanced the stochasticStrutLattice API with booleanType to support combine, subtract, and intersect operations on the outer 

body of stochastic lattices. 

 

Structure 

 

• Added API support for SimSolid reaction forces. 

• Added seam weld capabilities. 

• Added support to associate variables to forces, pressures, torques, enforced displacements, and angular velocity/acceleration. 

 

Enhancements 
 

• Multiselection is allowed when creating contacts using At Free Joints [INSPIRE-44461] 

• Flex body and design space are not allowed to be applied simultaneously. [INSPIRE-44236] 

• Improved performance for File > New and File > Open operations [Inspire-44644] 

• Variable creation for Joint friction properties [INSPIRE-45302] 

• Added Contact to reports [INSPIRE-44450] 

• Added Thickness to reports [INSPIRE-44136] 

• Added the ability to include videos in reports. [INSPIRE-42754] 

• Python API: Support inspire.getRunHistoryPath() in batch mode [INSPIRE-43910] 

• Python API: Support hiding characters option on LineEdit [INSPIRE-43108] 

• Python API: Support RGB color values in inspire.highlight function [INSPIRE-44960] 

• A warning message is now displayed when you enter a Start Time greater than the Simulation End Time. [INSPIRE-44563] 

• A warning message is now displayed when creating the flex body to prevent Flexible for Motion and Design Space options from 

being defined simultaneously on a part. [INSPIRE-44236] 

• Removed the Move tool from the Pin Joint microdialog, as it is not needed for this joint type [INSPIRE-41548] 

• Heat source value can be used as a Design Variable. [INSPIRE-43497] 

• In Part Refinement and Wall Refinement, surface mesh size is now based on voxel refinement settings. [INSPIRE-44588] 

• For consistency, Specific Heat is now designated with the symbol Cp in the Materials database. [INSPIRE-44811] 

 

 

Resolved Issues 
 

• Python API: unable to create an offset reference plane on a face that has a planar feature with a circular hole [INSPIRE-44987] 

• Failure to solve an Eigen analysis using At Eq. and FlexContact+ options [INSPIRE-44439] 
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• The Joint microdialog disappears when the joint type is changed from Grounded Sliding Pin to Ball and Socket. [INSPIRE-

45298] 

• No longer display a message about incompatibility between motion analysis and the SimSolid solver if the structural solver is set to 

SimSolid in Preferences when solving a motion analysis [INSPIRE-42838] 

• Fixed an issue with streamlines disappearing into wall boundaries [INSPIRE-44599] 

• Fixed an issue with termination of streamlines before reaching the outlets [INSPIRE-42560] 

 

Known Issues 
 

• The application can crash on Linux after creating a box selection in the Fit and Shape Variables tools on the PolyNURBS ribbon. 

[INSPIRE-44324] 
• Boundary conditions applied directly to an implicit model may change if the implicit part is modified directly or through another 

variable. Please consider applying loads directly on CAD parts and use contacts to perform these changes. [INSPIRE-45919] 
• Kinetic Energy result values change depending on Motion solver units used. The workaround is to use MKS Model units in 2023.1 

or MKS Motion Solver units in 2024/2024.1/2025. [INSPIRE-45979] 
• When running a Design Exploration for Motion, runs will fail if, under the Motion Run Settings, the Generate Animation File option 

is set to Include All Data. The workaround is to set it to the default (Auto). [INSPIRE-46325]  
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Learn More About Inspire 
 

You can learn more about new and existing features in Inspire using the following resources: 

 

In-Application User Assistance 
Inspire provides two types of user assistance. Enhanced tooltips appear when you hover over icons and other features. They describe 

what the tool does.  

 

 

Workflow help appears when you select a tool that opens a guide panel, guide bar, or microdialog. The text prompts you what to do 

next.  

 

 

Click  to view additional tips and shortcuts. Some tools also include a video . 
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Online and Offline Help 

Press F1 or select File > Help > Help to view the online help.  

 

You can download an offline version by selecting File > Help > Download Offline Help. An internet connection is required to 

download. 
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Supported Languages  

The language for the user interface and online help can be changed in the Preferences under Workspace > Language. User interface 

text is available in English, Chinese, French, German, Italian, Japanese, Korean, Portuguese, and Spanish.  

The online and offline help is available in English at the time of release, and in Chinese, Japanese, and Korean generally 1 to 2 months 

after release. If a language is selected in the Preferences that is supported for the user interface text but not for the help, the English 

help is shown. Similarly, if an unsupported language is selected in the Download Offline Help dialog, the English offline help will be 

downloaded instead. 
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